summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-volume-respect-PATH.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-27 18:41:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-11-07 21:01:12 +0100
commit1badc85068ee0be2a028c1b94a3dd285901bc391 (patch)
treeeeae4be76875527afb24f2a3f41d331f23c74403 /gnu/packages/patches/ceph-volume-respect-PATH.patch
parente2568df74e46b6ab5b9d63a78dd805f8018848ab (diff)
downloadguix-patches-1badc85068ee0be2a028c1b94a3dd285901bc391.tar
guix-patches-1badc85068ee0be2a028c1b94a3dd285901bc391.tar.gz
gnu: ceph: Update to 13.2.2.
* gnu/packages/patches/ceph-skip-unittest_blockdev.patch: Adjust for 13.2.2. * gnu/packages/patches/ceph-rocksdb-compat.patch: Delete file. * gnu/packages/patches/ceph-detect-rocksdb.patch, gnu/packages/patches/ceph-volume-respect-PATH.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/storage.scm (ceph): Update to 13.2.2. [source]: Don't remove src/dpdk, which has been moved to src/spdk/dpdk and is purged elsewhere. Drop bundled rapidjson. Adjust patch list. [arguments]: Add "-DWITH_MGR_DASHBOARD_FRONTEND=OFF" and "-DWITH_SPDK=OFF" to #:configure-flags. Drop obsolete "-DWITH_EMBEDDED". Add workaround for <https://bugs.gnu.org/30756>. Remove obsolete test substitution. Rework 'wrap-python-script' to be less verbose and wrap more scripts. [native-inputs]: Add GCC-7. [inputs]: Add OATH-TOOLKIT, RAPIDJSON and PYTHON2-SIX.
Diffstat (limited to 'gnu/packages/patches/ceph-volume-respect-PATH.patch')
-rw-r--r--gnu/packages/patches/ceph-volume-respect-PATH.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-volume-respect-PATH.patch b/gnu/packages/patches/ceph-volume-respect-PATH.patch
new file mode 100644
index 0000000000..08a9a15ddd
--- /dev/null
+++ b/gnu/packages/patches/ceph-volume-respect-PATH.patch
@@ -0,0 +1,22 @@
+Look for required tools in $PATH instead of just a handful locations.
+
+diff --git a/src/ceph-volume/ceph_volume/util/system.py b/src/ceph-volume/ceph_volume/util/system.py
+index b637f023a4..14516e1c65 100644
+--- a/src/ceph-volume/ceph_volume/util/system.py
++++ b/src/ceph-volume/ceph_volume/util/system.py
+@@ -33,14 +33,7 @@ def generate_uuid():
+
+ def which(executable):
+ """find the location of an executable"""
+- locations = (
+- '/usr/local/bin',
+- '/bin',
+- '/usr/bin',
+- '/usr/local/sbin',
+- '/usr/sbin',
+- '/sbin',
+- )
++ locations = os.getenv('PATH').split(':')
+
+ for location in locations:
+ executable_path = os.path.join(location, executable)