summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
commit84157bb8bf2c610584e0836047da4c710f8eaf76 (patch)
treebe5d8c7238e32802221db55a3ee83e7f6a58affb /gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
parentfa63939acba69e11df44073a7eb687bd2ba48349 (diff)
parent03d0aa8b22223b67ec9bbd363c4d5800efdbaf82 (diff)
downloadguix-patches-84157bb8bf2c610584e0836047da4c710f8eaf76.tar
guix-patches-84157bb8bf2c610584e0836047da4c710f8eaf76.tar.gz
Merge branch 'master' into core-updates
Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698.
Diffstat (limited to 'gnu/packages/patches/ceph-skip-collect-sys-info-test.patch')
-rw-r--r--gnu/packages/patches/ceph-skip-collect-sys-info-test.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
new file mode 100644
index 0000000000..f210799254
--- /dev/null
+++ b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
@@ -0,0 +1,29 @@
+This test fails because /etc/os-release is not available.
+
+diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
+index 288dd37db1..95b6cd4b30 100644
+--- a/src/test/common/test_util.cc
++++ b/src/test/common/test_util.cc
+@@ -31,19 +31,3 @@ TEST(util, unit_to_bytesize)
+
+ ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
+ }
+-
+-#if defined(__linux__)
+-TEST(util, collect_sys_info)
+-{
+- map<string, string> sys_info;
+-
+- CephContext *cct = (new CephContext(CEPH_ENTITY_TYPE_CLIENT))->get();
+- collect_sys_info(&sys_info, cct);
+-
+- ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
+- ASSERT_TRUE(sys_info.find("distro_version") != sys_info.end());
+- ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
+-
+- cct->put();
+-}
+-#endif
+--
+2.11.1
+