summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-11-05 22:49:43 +0100
committerMarius Bakke <marius@gnu.org>2021-11-06 17:41:41 +0100
commit1525443e02f5462934d32904973692541b7057d7 (patch)
treea250ff22e86bbc3d70c6a6fb991cb069f56e7e84 /gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
parent075df3d3e2f86ad2548075969b34402a3c40ec42 (diff)
downloadguix-patches-1525443e02f5462934d32904973692541b7057d7.tar
guix-patches-1525443e02f5462934d32904973692541b7057d7.tar.gz
gnu: ceph: Update to 16.2.6.
* gnu/packages/storage.scm (ceph): Update to 16.2.6. [source](patches): Add two new patches. Remove one obsolete. [source](snippet): Unbundle fmt. [arguments]: Remove -DWITH_PYTHON3 from #:configure-flags. Add -DWITH_SYSTEMD. Adjust RUNPATH substitution, and the wrap-python-scripts phase, for upstream changes. Remove trailing #t's. [inputs]: Remove PYTHON-SIX and PYTHON-WRAPPER. Add FMT, ICU4C, PYTHON-PYYAML, PYTHON, and SQLITE. * gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: Delete file. * gnu/packages/patches/ceph-boost-compat.patch, gnu/packages/patches/ceph-rocksdb-compat.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/ceph-fix-snappy-breaking-change.patch')
-rw-r--r--gnu/packages/patches/ceph-fix-snappy-breaking-change.patch13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch b/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
deleted file mode 100644
index 7a10e2e4ae..0000000000
--- a/gnu/packages/patches/ceph-fix-snappy-breaking-change.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Patch tracked upstream at https://tracker.ceph.com/issues/50934
-
---- a/src/compressor/snappy/SnappyCompressor.h
-+++ b/src/compressor/snappy/SnappyCompressor.h
-@@ -96,7 +96,7 @@ class SnappyCompressor : public Compressor {
- if (qat_enabled)
- return qat_accel.decompress(p, compressed_len, dst);
- #endif
-- snappy::uint32 res_len = 0;
-+ uint32_t res_len = 0;
- BufferlistSource source_1(p, compressed_len);
- if (!snappy::GetUncompressedLength(&source_1, &res_len)) {
- return -1;