summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/calibre-msgpack-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-08 19:18:05 +0200
committerMarius Bakke <marius@gnu.org>2020-06-08 19:18:05 +0200
commitd79ec4fd343bc2a72652aa3a4b4ae14bd8df88ac (patch)
tree4a606d4664cccc0e27077b5a50c225c34d5eb7a9 /gnu/packages/patches/calibre-msgpack-compat.patch
parent7b7b3cef7e46b8eae03fcfb397bed15727d2dff9 (diff)
downloadguix-patches-d79ec4fd343bc2a72652aa3a4b4ae14bd8df88ac.tar
guix-patches-d79ec4fd343bc2a72652aa3a4b4ae14bd8df88ac.tar.gz
gnu: calibre: Update to 4.18.0.
* gnu/packages/patches/calibre-remove-test-bs4.patch, gnu/packages/patches/calibre-msgpack-compat.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/ebook.scm (calibre): Update to 4.18.0. [source](patches): Remove obsolete patches. [source](snippet): Disable test for bundled odfpy. [inputs]: Add HUNSPELL, HYPHEN, PYTHON2-BEAUTIFULSOUP4, PYTHON2-PYQTWEBENGINE, and QTWEBENGINE. [arguments]: Add phase 'patch-more-shebangs'. Adjust configure phase to set HOME and make fonts available. Simplify one substitution, and provide the absolute file name of 'sip'.
Diffstat (limited to 'gnu/packages/patches/calibre-msgpack-compat.patch')
-rw-r--r--gnu/packages/patches/calibre-msgpack-compat.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/calibre-msgpack-compat.patch b/gnu/packages/patches/calibre-msgpack-compat.patch
deleted file mode 100644
index 9920103bea..0000000000
--- a/gnu/packages/patches/calibre-msgpack-compat.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Fix deserialization with msgpack 1.0.
-
-Patch copied from upstream source repository:
-https://github.com/kovidgoyal/calibre/commit/0ff41ac64994ec11b7859fc004c94d08769e3af3
-
-diff --git a/src/calibre/utils/serialize.py b/src/calibre/utils/serialize.py
-index f5d560c468..c35ae53849 100644
---- a/src/calibre/utils/serialize.py
-+++ b/src/calibre/utils/serialize.py
-@@ -110,7 +110,7 @@ def msgpack_decoder(code, data):
- def msgpack_loads(dump, use_list=True):
- # use_list controls whether msgpack arrays are unpacked as lists or tuples
- import msgpack
-- return msgpack.unpackb(dump, ext_hook=msgpack_decoder, raw=False, use_list=use_list)
-+ return msgpack.unpackb(dump, ext_hook=msgpack_decoder, raw=False, use_list=use_list, strict_map_key=False)
-
-
- def json_loads(data):