summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/cairo-CVE-2018-19876.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-04-22 19:21:51 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-04-23 18:27:26 +0800
commit2ab4f4c950ffa7ca40271a534cb3bed997672138 (patch)
tree60a900d36a2dd87b6e0f098f16cf0d535019c6cf /gnu/packages/patches/cairo-CVE-2018-19876.patch
parenta738a663a99ea63078cbba63d9b267e123f475d5 (diff)
downloadguix-patches-2ab4f4c950ffa7ca40271a534cb3bed997672138.tar
guix-patches-2ab4f4c950ffa7ca40271a534cb3bed997672138.tar.gz
gnu: cairo: Reintroduce security patches [security fixes].
Two patches were accidentally removed in commit f94cdc86f644984ca83164d40b17e7eed6e22091. * gnu/packages/patches/cairo-CVE-2018-19876.patch, gnu/packages/patches/cairo-CVE-2020-35492.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gtk.scm (cairo)[patches]: Apply them.
Diffstat (limited to 'gnu/packages/patches/cairo-CVE-2018-19876.patch')
-rw-r--r--gnu/packages/patches/cairo-CVE-2018-19876.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/patches/cairo-CVE-2018-19876.patch b/gnu/packages/patches/cairo-CVE-2018-19876.patch
new file mode 100644
index 0000000000..c0fba2ecaa
--- /dev/null
+++ b/gnu/packages/patches/cairo-CVE-2018-19876.patch
@@ -0,0 +1,37 @@
+Copied from Debian.
+
+From: Carlos Garcia Campos <cgarcia@igalia.com>
+Date: Mon, 19 Nov 2018 12:33:07 +0100
+Subject: ft: Use FT_Done_MM_Var instead of free when available in
+ cairo_ft_apply_variations
+
+Fixes a crash when using freetype >= 2.9
+
+[This is considered to be security-sensitive because WebKitGTK+ sets its
+own memory allocator, which is not compatible with system free(), making
+this a remotely triggerable denial of service or memory corruption.]
+
+Origin: upstream, commit:90e85c2493fdfa3551f202ff10282463f1e36645
+Bug: https://gitlab.freedesktop.org/cairo/cairo/merge_requests/5
+Bug-Debian: https://bugs.debian.org/916389
+Bug-CVE: CVE-2018-19876
+---
+ src/cairo-ft-font.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c
+index 325dd61..981973f 100644
+--- a/src/cairo-ft-font.c
++++ b/src/cairo-ft-font.c
+@@ -2393,7 +2393,11 @@ skip:
+ done:
+ free (coords);
+ free (current_coords);
++#if HAVE_FT_DONE_MM_VAR
++ FT_Done_MM_Var (face->glyph->library, ft_mm_var);
++#else
+ free (ft_mm_var);
++#endif
+ }
+ }
+