summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bsd-games-stdio.h.patch
diff options
context:
space:
mode:
authorVitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>2020-08-25 18:26:38 +0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-04 15:15:47 +0100
commit95024494f31c3176bcd2238662e7b7868acc2882 (patch)
tree634c55074ed9eb6342e147854cf9f215be2a3f43 /gnu/packages/patches/bsd-games-stdio.h.patch
parentdd2330a89bb4e8c149916916ecc4cc669f733ee8 (diff)
downloadguix-patches-95024494f31c3176bcd2238662e7b7868acc2882.tar
guix-patches-95024494f31c3176bcd2238662e7b7868acc2882.tar.gz
gnu: Add bsd-games.
* gnu/packages/games.scm (bsd-games): New variable. New patches, taken from Arch and Debian: * gnu/packages/patches/bsd-games-2.17-64bit.patch * gnu/packages/patches/bsd-games-bad-ntohl-cast.patch * gnu/packages/patches/bsd-games-gamescreen.h.patch * gnu/packages/patches/bsd-games-getline.patch * gnu/packages/patches/bsd-games-null-check.patch * gnu/packages/patches/bsd-games-number.c-and-test.patch * gnu/packages/patches/bsd-games-prevent-name-collisions.patch * gnu/packages/patches/bsd-games-stdio.h.patch New patches with our customizations (configure-config built after Arch's): * gnu/packages/patches/bsd-games-add-configure-config.patch * gnu/packages/patches/bsd-games-add-wrapper.patch * gnu/packages/patches/bsd-games-dont-install-empty-files.patch Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/patches/bsd-games-stdio.h.patch')
-rw-r--r--gnu/packages/patches/bsd-games-stdio.h.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/bsd-games-stdio.h.patch b/gnu/packages/patches/bsd-games-stdio.h.patch
new file mode 100644
index 0000000000..1c3a402042
--- /dev/null
+++ b/gnu/packages/patches/bsd-games-stdio.h.patch
@@ -0,0 +1,14 @@
+diff -ru a/include/stdio.h b/include/stdio.h
+--- a/include/stdio.h 2000-08-04 10:24:39.000000000 +1000
++++ b/include/stdio.h 2005-06-18 14:26:35.000000000 +1000
+@@ -34,6 +34,10 @@
+ #include <bsd-games.h>
+ #include_next <stdio.h>
+
++__BEGIN_DECLS
++
+ #ifndef HAVE_fgetln
+ extern char *fgetln(FILE *stream, size_t *len);
+ #endif
++
++__END_DECLS