summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/blender-2.79-gcc9.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-01-09 16:34:12 -0500
committerLeo Famulari <leo@famulari.name>2022-01-09 16:35:20 -0500
commit1684ed6537fbd91ae5c14fb0314564e71799d390 (patch)
tree083fc4af3ff417b1a00222ee0b5156a66d3f8152 /gnu/packages/patches/blender-2.79-gcc9.patch
parent23da063ea3bb6a579f0fb87d2e5e00fed9962775 (diff)
downloadguix-patches-1684ed6537fbd91ae5c14fb0314564e71799d390.tar
guix-patches-1684ed6537fbd91ae5c14fb0314564e71799d390.tar.gz
gnu: Remove leftover patches for Blender 2.79.
This is a followup to commit 23da063ea3bb6a579f0fb87d2e5e00fed9962775. * gnu/packages/patches/blender-2.79-gcc8.patch, gnu/packages/patches/blender-2.79-gcc9.patch, gnu/packages/patches/blender-2.79-newer-ffmpeg.patch, gnu/packages/patches/blender-2.79-oiio2.patch, gnu/packages/patches/blender-2.79-python-3.7-fix.patch, gnu/packages/patches/blender-2.79-python-3.8-fix.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/blender-2.79-gcc9.patch')
-rw-r--r--gnu/packages/patches/blender-2.79-gcc9.patch53
1 files changed, 0 insertions, 53 deletions
diff --git a/gnu/packages/patches/blender-2.79-gcc9.patch b/gnu/packages/patches/blender-2.79-gcc9.patch
deleted file mode 100644
index d538a02620..0000000000
--- a/gnu/packages/patches/blender-2.79-gcc9.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-commit e6d803fd4a383cecf8c643095f093a31c944b785
-Author: Robert-André Mauchin <zebob.m@gmail.com>
-Date: Wed Apr 3 01:36:52 2019 +0200
-
- Fix for GCC9 new OpenMP data sharing
-
- GCC 9 started implementing the OpenMP 4.0 and later behavior. When not using
- default clause or when using default(shared), this makes no difference, but
- if using default(none), previously the choice was not specify the const
- qualified variables on the construct at all, or specify in firstprivate
- clause. In GCC 9 as well as for OpenMP 4.0 compliance, those variables need
- to be specified on constructs in which they are used, either in shared or
- in firstprivate clause. Specifying them in firstprivate clause is one way to
- achieve compatibility with both older GCC versions and GCC 9,
- another option is to drop the default(none) clause.
-
- This patch thus drops the default(none) clause.
-
- See https://gcc.gnu.org/gcc-9/porting_to.html#ompdatasharing
-
- Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
-
-diff --git a/intern/elbeem/intern/solver_main.cpp b/intern/elbeem/intern/solver_main.cpp
-index 68f7c04cd54..514087b6130 100644
---- a/intern/elbeem/intern/solver_main.cpp
-+++ b/intern/elbeem/intern/solver_main.cpp
-@@ -381,7 +381,7 @@ LbmFsgrSolver::mainLoop(const int lev)
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \
-@@ -1126,7 +1126,7 @@ LbmFsgrSolver::preinitGrids()
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \
-@@ -1164,7 +1164,7 @@ LbmFsgrSolver::standingFluidPreinit()
- GRID_REGION_INIT();
- #if PARALLEL==1
- const int gDebugLevel = ::gDebugLevel;
--#pragma omp parallel default(none) num_threads(mNumOMPThreads) \
-+#pragma omp parallel num_threads(mNumOMPThreads) \
- reduction(+: \
- calcCurrentMass,calcCurrentVolume, \
- calcCellsFilled,calcCellsEmptied, \