summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/patches/aws-sdk-cpp-disable-werror.patch')
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-werror.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
new file mode 100644
index 0000000000..249c299239
--- /dev/null
+++ b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/cmake/compiler_settings.cmake
++++ b/cmake/compiler_settings.cmake
+@@ -53,7 +53,7 @@ macro(set_gcc_flags)
+ endmacro()
+
+ macro(set_gcc_warnings)
+- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
++ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
+ if(COMPILER_CLANG)
+ if(PLATFORM_ANDROID)
+ # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.