summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch')
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch b/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
deleted file mode 100644
index 3b582d9628..0000000000
--- a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-+++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
-@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxy)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxy)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
-+//}
-
- TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
- {
-@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
- makeRandomHttpRequest(httpClient, false);
- }
-
--TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
--{
-- ClientConfiguration configuration = makeClientConfigurationWithProxy();
-- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-- auto httpClient = CreateHttpClient(configuration);
-- makeRandomHttpRequest(httpClient, true);
--}
-+//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
-+//{
-+// ClientConfiguration configuration = makeClientConfigurationWithProxy();
-+// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
-+// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
-+// auto httpClient = CreateHttpClient(configuration);
-+// makeRandomHttpRequest(httpClient, true);
-+//}
-
- // TODO: Pending Fix on Windows.
- #if ENABLE_CURL_CLIENT