summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-c-http-cmake-prefix.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 13:58:33 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commitd9b8cfd6c649fb246f7fdf2dc283c27c4afae100 (patch)
tree82e32d66e69e3216cd99ef85bc4b1a638e8a2a34 /gnu/packages/patches/aws-c-http-cmake-prefix.patch
parentd061193e786b0a8d5df9e4adf713964eb2d2c965 (diff)
downloadguix-patches-d9b8cfd6c649fb246f7fdf2dc283c27c4afae100.tar
guix-patches-d9b8cfd6c649fb246f7fdf2dc283c27c4afae100.tar.gz
gnu: Add aws-c-http.
* gnu/packages/c.scm (aws-c-http): New variable. * gnu/packages/patches/aws-c-http-cmake-prefix.patch, gnu/packages/patches/aws-c-http-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-c-http-cmake-prefix.patch')
-rw-r--r--gnu/packages/patches/aws-c-http-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-http-cmake-prefix.patch b/gnu/packages/patches/aws-c-http-cmake-prefix.patch
new file mode 100644
index 0000000000..ec650a7e82
--- /dev/null
+++ b/gnu/packages/patches/aws-c-http-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -7,6 +7,10 @@ endif()
+
+ option(ENABLE_PROXY_INTEGRATION_TESTS "Whether to run the proxy integration tests that rely on a proxy server installed and running locally" OFF)
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()