summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:47:45 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commitddab5244dfa85e5ad73da80c3169fe790387743b (patch)
tree2aaf4f58f4398c60278cbb16dba9b1108f27e36a /gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
parent4c66a8deb5f51fd4f944fb62c43aa1e2a477711c (diff)
downloadguix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar
guix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar.gz
gnu: Add aws-c-event-stream.
* gnu/packages/c.scm (aws-c-event-stream): New variable. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch')
-rw-r--r--gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
new file mode 100644
index 0000000000..79655a910b
--- /dev/null
+++ b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,10 @@
+ cmake_minimum_required (VERSION 3.1)
+ project (aws-c-event-stream C)
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()