summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-c-auth-cmake-prefix.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-04-30 14:00:27 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:58 +0200
commit1f1bb634c321b26b424c58e1fcdd21703b58f171 (patch)
tree806bc0247dbfb9c0e1a5be8140640d2bfdc59974 /gnu/packages/patches/aws-c-auth-cmake-prefix.patch
parent2069238cb35fee5f8da1dd8fab6df4749bee135b (diff)
downloadguix-patches-1f1bb634c321b26b424c58e1fcdd21703b58f171.tar
guix-patches-1f1bb634c321b26b424c58e1fcdd21703b58f171.tar.gz
gnu: Add aws-c-auth.
* gnu/packages/c.scm (aws-c-auth): New variable. * gnu/packages/patches/aws-c-auth-cmake-prefix.patch, gnu/packages/patches/aws-c-auth-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-c-auth-cmake-prefix.patch')
-rw-r--r--gnu/packages/patches/aws-c-auth-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-auth-cmake-prefix.patch b/gnu/packages/patches/aws-c-auth-cmake-prefix.patch
new file mode 100644
index 0000000000..da3e4eb4a5
--- /dev/null
+++ b/gnu/packages/patches/aws-c-auth-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()