summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-10 17:49:14 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-10 17:49:14 +0100
commit8515ea12d283632e7d0103286e679542d896058b (patch)
tree5c71f09864a027b13a6cb3c236c1079608f639c1 /gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch
parent74361d3ee8c1524ee3f3496f113b9a8bf644e023 (diff)
downloadguix-patches-8515ea12d283632e7d0103286e679542d896058b.tar
guix-patches-8515ea12d283632e7d0103286e679542d896058b.tar.gz
gnu: audiofile: Shorten patch file names.
At least 'audiofile-division-by-zero-BlockCodec-runPull.patch' could end up not being included in a tarball. * gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch: Rename to... * gnu/packages/patches/audiofile-check-number-of-coefficients.patch: ... this. * gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch: Rename to... * gnu/packages/patches/audiofile-division-by-zero.patch: ....this. * gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: Rename to... * gnu/packages/patches/audiofile-function-signature.patch: ... this. * gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch: Rename to.... * gnu/packages/patches/audiofile-multiply-overflow.patch: ... this. * gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch: Rename to... * gnu/packages/patches/audiofile-overflow-in-MSADPCM.patch: ... this. * gnu/packages/audio.scm (audiofile)[source]: Adjust accordingly. * gnu/local.mk (dist_patch_DATA): Likewise.
Diffstat (limited to 'gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch')
-rw-r--r--gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch b/gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch
deleted file mode 100644
index 35627d3869..0000000000
--- a/gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From: Antonio Larrosa <larrosa@kde.org>
-Date: Fri, 10 Mar 2017 15:40:02 +0100
-Subject: Fix signature of multiplyCheckOverflow. It returns a bool, not an int
-
----
- libaudiofile/modules/MSADPCM.cpp | 2 +-
- sfcommands/sfconvert.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/libaudiofile/modules/MSADPCM.cpp b/libaudiofile/modules/MSADPCM.cpp
-index ef9c38c..d8c9553 100644
---- a/libaudiofile/modules/MSADPCM.cpp
-+++ b/libaudiofile/modules/MSADPCM.cpp
-@@ -116,7 +116,7 @@ int firstBitSet(int x)
- #define __has_builtin(x) 0
- #endif
-
--int multiplyCheckOverflow(int a, int b, int *result)
-+bool multiplyCheckOverflow(int a, int b, int *result)
- {
- #if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
- return __builtin_mul_overflow(a, b, result);
-diff --git a/sfcommands/sfconvert.c b/sfcommands/sfconvert.c
-index 970a3e4..367f7a5 100644
---- a/sfcommands/sfconvert.c
-+++ b/sfcommands/sfconvert.c
-@@ -60,7 +60,7 @@ int firstBitSet(int x)
- #define __has_builtin(x) 0
- #endif
-
--int multiplyCheckOverflow(int a, int b, int *result)
-+bool multiplyCheckOverflow(int a, int b, int *result)
- {
- #if (defined __GNUC__ && __GNUC__ >= 5) || ( __clang__ && __has_builtin(__builtin_mul_overflow))
- return __builtin_mul_overflow(a, b, result);