summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-10 17:49:14 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-10 17:49:14 +0100
commit8515ea12d283632e7d0103286e679542d896058b (patch)
tree5c71f09864a027b13a6cb3c236c1079608f639c1 /gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch
parent74361d3ee8c1524ee3f3496f113b9a8bf644e023 (diff)
downloadguix-patches-8515ea12d283632e7d0103286e679542d896058b.tar
guix-patches-8515ea12d283632e7d0103286e679542d896058b.tar.gz
gnu: audiofile: Shorten patch file names.
At least 'audiofile-division-by-zero-BlockCodec-runPull.patch' could end up not being included in a tarball. * gnu/packages/patches/audiofile-Check-the-number-of-coefficients.patch: Rename to... * gnu/packages/patches/audiofile-check-number-of-coefficients.patch: ... this. * gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch: Rename to... * gnu/packages/patches/audiofile-division-by-zero.patch: ....this. * gnu/packages/patches/audiofile-signature-of-multiplyCheckOverflow.patch: Rename to... * gnu/packages/patches/audiofile-function-signature.patch: ... this. * gnu/packages/patches/audiofile-Fix-multiply-overflow-sfconvert.patch: Rename to.... * gnu/packages/patches/audiofile-multiply-overflow.patch: ... this. * gnu/packages/patches/audiofile-Fix-overflow-in-MSADPCM-decodeSam.patch: Rename to... * gnu/packages/patches/audiofile-overflow-in-MSADPCM.patch: ... this. * gnu/packages/audio.scm (audiofile)[source]: Adjust accordingly. * gnu/local.mk (dist_patch_DATA): Likewise.
Diffstat (limited to 'gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch')
-rw-r--r--gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch21
1 files changed, 0 insertions, 21 deletions
diff --git a/gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch b/gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch
deleted file mode 100644
index e001133916..0000000000
--- a/gnu/packages/patches/audiofile-division-by-zero-BlockCodec-runPull.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Antonio Larrosa <larrosa@kde.org>
-Date: Thu, 9 Mar 2017 10:21:18 +0100
-Subject: Check for division by zero in BlockCodec::runPull
-
----
- libaudiofile/modules/BlockCodec.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/libaudiofile/modules/BlockCodec.cpp b/libaudiofile/modules/BlockCodec.cpp
-index 4731be1..eb2fb4d 100644
---- a/libaudiofile/modules/BlockCodec.cpp
-+++ b/libaudiofile/modules/BlockCodec.cpp
-@@ -47,7 +47,7 @@ void BlockCodec::runPull()
-
- // Read the compressed data.
- ssize_t bytesRead = read(m_inChunk->buffer, m_bytesPerPacket * blockCount);
-- int blocksRead = bytesRead >= 0 ? bytesRead / m_bytesPerPacket : 0;
-+ int blocksRead = (bytesRead >= 0 && m_bytesPerPacket > 0) ? bytesRead / m_bytesPerPacket : 0;
-
- // Decompress into m_outChunk.
- for (int i=0; i<blocksRead; i++)