summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/audacity-add-include.patch
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-12-09 16:54:26 -0500
committerKei Kebreau <kkebreau@posteo.net>2020-12-27 16:42:02 -0500
commit3e6c114241725a22e4d190c3f9ee15c3c701461a (patch)
tree5bdbfcadcdfd6261e36f9063bfad18b4152d8ea6 /gnu/packages/patches/audacity-add-include.patch
parentfc5f56eaf4ef1dc09a7e4062c2b973aa9f27b285 (diff)
downloadguix-patches-3e6c114241725a22e4d190c3f9ee15c3c701461a.tar
guix-patches-3e6c114241725a22e4d190c3f9ee15c3c701461a.tar.gz
gnu: audacity: Update to 2.4.2.
* gnu/packages/audio.scm (audacity): Update to 2.4.2. [source]: Add patch. Don't delete portaudio-v19, since only the bundled copy can be built. [build-system]: Switch to cmake-build-system. [inputs]: Remove portaudio. [arguments]: Adjust configure flags for CMake. Remove 'fix-sbsms-check phase. Add 'comment-out-revision-ident phase. * gnu/local.mk (dist_patch_DATA): Register patch. * gnu/packages/patches/audacity-add-include.patch: New file.
Diffstat (limited to 'gnu/packages/patches/audacity-add-include.patch')
-rw-r--r--gnu/packages/patches/audacity-add-include.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/audacity-add-include.patch b/gnu/packages/patches/audacity-add-include.patch
new file mode 100644
index 0000000000..a7f27918e7
--- /dev/null
+++ b/gnu/packages/patches/audacity-add-include.patch
@@ -0,0 +1,15 @@
+Without <sys/time.h>, gettimeofday is undefined.
+
+diff --git a/src/AudioIO.cpp b/src/AudioIO.cpp
+index 0187e3962..e15d55f4c 100644
+--- a/src/AudioIO.cpp
++++ b/src/AudioIO.cpp
+@@ -479,6 +479,8 @@ time warp info and AudioIOListener and whether the playback is looped.
+ #include "../lib-src/portmidi/porttime/porttime.h"
+ #include "../lib-src/header-substitutes/allegro.h"
+
++#include <sys/time.h>
++
+ #define MIDI_SLEEP 10 /* milliseconds */
+ // how long do we think the thread that fills MIDI buffers,
+ // if it is separate from the portaudio thread,