summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abiword-explictly-cast-bools.patch
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:28:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:40:25 +0300
commit64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98 (patch)
tree94a6305cb93edbe896ef713ab8ab9b0c53eed88c /gnu/packages/patches/abiword-explictly-cast-bools.patch
parent9a1bfd68a95fa91d3c80c2b77e0d69540cd2e8a9 (diff)
downloadguix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar
guix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar.gz
gnu: abiword: Update to 3.0.4.
* gnu/packages/abiword.scm (abiword): Update to 3.0.4. [source](patches): Remove "abiword-black-drawing-with-gtk322.patch" patch. Delete merged to upstream patch hunks in "abiword-explictly-cast-bools.patch" patch. * gnu/packages/patches/abiword-black-drawing-with-gtk322.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove this.
Diffstat (limited to 'gnu/packages/patches/abiword-explictly-cast-bools.patch')
-rw-r--r--gnu/packages/patches/abiword-explictly-cast-bools.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/patches/abiword-explictly-cast-bools.patch b/gnu/packages/patches/abiword-explictly-cast-bools.patch
index 97ae6653c2..1d026a68b0 100644
--- a/gnu/packages/patches/abiword-explictly-cast-bools.patch
+++ b/gnu/packages/patches/abiword-explictly-cast-bools.patch
@@ -13,24 +13,6 @@ casted.
}
/*
-@@ -161,7 +161,7 @@ bool UT_JPEG_getDimensions(const UT_ByteBuf* pBB, UT_sint32& iImageWidth,
- /* set the data source */
- _JPEG_ByteBufSrc (&cinfo, pBB);
-
-- jpeg_read_header(&cinfo, TRUE);
-+ jpeg_read_header(&cinfo, (boolean)TRUE);
- jpeg_start_decompress(&cinfo);
- iImageWidth = cinfo.output_width;
- iImageHeight = cinfo.output_height;
-@@ -189,7 +189,7 @@ bool UT_JPEG_getRGBData(const UT_ByteBuf* pBB, UT_Byte* pDest, UT_sint32 iDestRo
- /* set the data source */
- _JPEG_ByteBufSrc (&cinfo, pBB);
-
-- jpeg_read_header(&cinfo, TRUE);
-+ jpeg_read_header(&cinfo, (boolean)TRUE);
- jpeg_start_decompress(&cinfo);
-
- int row_stride = cinfo.output_width * cinfo.output_components;
In the following file, we also need to reverse header include order: JPEG needs