summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:28:07 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-09 02:40:25 +0300
commit64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98 (patch)
tree94a6305cb93edbe896ef713ab8ab9b0c53eed88c /gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
parent9a1bfd68a95fa91d3c80c2b77e0d69540cd2e8a9 (diff)
downloadguix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar
guix-patches-64c1e6fe4ab440e2bb3b5fe6ed7a659f1cdd5b98.tar.gz
gnu: abiword: Update to 3.0.4.
* gnu/packages/abiword.scm (abiword): Update to 3.0.4. [source](patches): Remove "abiword-black-drawing-with-gtk322.patch" patch. Delete merged to upstream patch hunks in "abiword-explictly-cast-bools.patch" patch. * gnu/packages/patches/abiword-black-drawing-with-gtk322.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove this.
Diffstat (limited to 'gnu/packages/patches/abiword-black-drawing-with-gtk322.patch')
-rw-r--r--gnu/packages/patches/abiword-black-drawing-with-gtk322.patch49
1 files changed, 0 insertions, 49 deletions
diff --git a/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch b/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
deleted file mode 100644
index 88a5ca4c38..0000000000
--- a/gnu/packages/patches/abiword-black-drawing-with-gtk322.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-commit 2ee38d1881aeea27bb49acc450631d813d1f28ba
-Author: Hubert Figuière <hub@figuiere.net>
-Date: Wed Dec 7 09:44:01 2016 -0500
-
- Bug 13815 - draw event should return TRUE
-
- This fix the black drawing regression witj Gtk3.22
-
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-index 780000e..10f8e00 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
-@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
- }
-
- #if GTK_CHECK_VERSION(3,0,0)
--gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
-+gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
- #else
--gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
-+gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- #endif
- {
- XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
-@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
- pView->draw(&rClip);
- #endif
- }
-- return FALSE;
-+ return TRUE;
- }
-
- static bool bScrollWait = false;
-diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
-index 30ee5d8..a0ff57f 100644
---- a/src/af/xap/gtk/xap_UnixFrameImpl.h
-+++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
-@@ -152,9 +152,9 @@ protected:
- static gint key_release_event(GtkWidget* w, GdkEventKey* e);
- static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
- #if GTK_CHECK_VERSION(3,0,0)
-- static gint draw(GtkWidget * w, cairo_t * cr);
-+ static gboolean draw(GtkWidget * w, cairo_t * cr);
- #else
-- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
-+ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
- #endif
- static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
- static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);