summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abcl-fix-build-xml.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-08 19:24:34 +0200
commitd1f3b333e6176a7879ab3742bbebb2a99f61a528 (patch)
tree8bd82ce68bd2534a48bf13c7256997f82dd1b3f4 /gnu/packages/patches/abcl-fix-build-xml.patch
parente01d384efcdaf564bbb221e43b81e087c8e2af06 (diff)
parent861907f01efb1cae7f260e8cb7b991d5034a486a (diff)
downloadguix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar
guix-patches-d1f3b333e6176a7879ab3742bbebb2a99f61a528.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/abcl-fix-build-xml.patch')
-rw-r--r--gnu/packages/patches/abcl-fix-build-xml.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/patches/abcl-fix-build-xml.patch b/gnu/packages/patches/abcl-fix-build-xml.patch
new file mode 100644
index 0000000000..dd315b4271
--- /dev/null
+++ b/gnu/packages/patches/abcl-fix-build-xml.patch
@@ -0,0 +1,50 @@
+ABCL's build calls the hostname command, and needs the internet to download
+JUnit. Neither of these are really required, though, so we can patch them out
+to make it build.
+
+We also remove the Implemetation-Build property that ends up in the manifest
+file, because it stores information about the time of the build, which makes
+it non-deterministic.
+
+--- a/build.xml
++++ b/build.xml
+@@ -327,7 +327,7 @@ from ${abcl.home.dir}
+ <property name="abcl.build.path"
+ value="${build.classes.dir}/org/armedbear/lisp/build"/>
+ <target name="abcl.stamp"
+- depends="abcl.compile,abcl.stamp.version,abcl.stamp.hostname">
++ depends="abcl.compile,abcl.stamp.version">
+ <mkdir dir="${abcl.build.path}/.."/>
+ <loadfile property="abcl.version"
+ srcFile="${abcl.version.path}"/>
+@@ -455,11 +455,6 @@ from ${abcl.home.dir}
+ value="${abcl.version}-${abcl.version.src}"/>
+ </target>
+
+- <target name="abcl.stamp.hostname" if="unix">
+- <exec executable="hostname" outputproperty="abcl.hostname"/>
+- <echo>abcl.hostname: ${abcl.hostname}</echo>
+- </target>
+-
+ <target name="abcl.system.uptodate">
+ <condition property="abcl.system.needs-update.p">
+ <and>
+@@ -500,8 +495,6 @@ from ${abcl.home.dir}
+ value="ABCL"/>
+ <attribute name="Implementation-Version"
+ value="${abcl.implementation.version}"/>
+- <attribute name="Implementation-Build"
+- value="${build}"/>
+ </section>
+ </manifest>
+ <metainf dir="${src.dir}/META-INF">
+@@ -1019,8 +1012,7 @@ ${basedir}/../cl-bench
+ </unzip>
+ </target>
+
+- <target name="abcl.test.compile"
+- depends="abcl.test.pre-compile">
++ <target name="abcl.test.compile" >
+ <mkdir dir="${abcl.test.classes.dir}"/>
+ <javac destdir="${abcl.test.classes.dir}"
+ classpathref="abcl.test.compile.classpath"