summaryrefslogtreecommitdiff
path: root/gnu/packages/patchelf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-15 23:27:56 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-15 23:27:56 +0100
commit3e778ad3af53e343550f4ec3d0b56f9bfe1fa2e3 (patch)
treef2c83b46cfdbaec390bf7259ab69cd1a08a67e23 /gnu/packages/patchelf.scm
parent2ed5b0f42c40b5eb8df462b3cff3399123423182 (diff)
downloadguix-patches-3e778ad3af53e343550f4ec3d0b56f9bfe1fa2e3.tar
guix-patches-3e778ad3af53e343550f4ec3d0b56f9bfe1fa2e3.tar.gz
gnu: Move libelf and patchelf to (gnu packages elf).
* gnu/packages/patchelf.scm (patchelf): Move to... * gnu/packages/elf.scm (patchelf): ... here. * gnu/packages/patchelf.scm: Remove. * gnu-system.am (GNU_SYSTEM_MODULES): Adjust accordingly. * gnu/packages/gcc.scm (libelf): Move to... * gnu/packages/elf.scm (libelf): ... here. * gnu/packages/cdrom.scm, gnu/packages/icu4c.scm, gnu/packages/samba.scm, gnu/packages/scheme.scm, gnu/packages/ssh.scm: Adjust references to (gnu packages patchelf).
Diffstat (limited to 'gnu/packages/patchelf.scm')
-rw-r--r--gnu/packages/patchelf.scm46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/patchelf.scm b/gnu/packages/patchelf.scm
deleted file mode 100644
index 1bbe010ce1..0000000000
--- a/gnu/packages/patchelf.scm
+++ /dev/null
@@ -1,46 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages patchelf)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public patchelf
- (package
- (name "patchelf")
- (version "0.6")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "http://nixos.org/releases/patchelf/patchelf-"
- version
- "/patchelf-"
- version
- ".tar.bz2"))
- (sha256
- (base32
- "00bw29vdsscsili65wcb5ay0gvg1w0ljd00sb5xc6br8bylpyzpw"))))
- (build-system gnu-build-system)
- (home-page "http://nixos.org/patchelf.html")
- (synopsis "Modify the dynamic linker and RPATH of ELF executables")
- (description
- "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
-changed.")
- (license gpl3+)))