summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorChristian Miller via Guix-patches via <guix-patches@gnu.org>2024-02-24 08:39:34 +0000
committerAndreas Enge <andreas@enge.fr>2024-02-26 16:48:41 +0100
commitbf17a01e06abc100651ed643f2d5c7fea07d37ba (patch)
tree4b4e73e6c258e3f6381c0d0e4f76113722dc3b8d /gnu/packages/password-utils.scm
parent8842826609f6e7b2af17f7fccaad0bdf2d9833bf (diff)
downloadguix-patches-bf17a01e06abc100651ed643f2d5c7fea07d37ba.tar
guix-patches-bf17a01e06abc100651ed643f2d5c7fea07d37ba.tar.gz
gnu: Add pass-coffin
* gnu/packages/password-utils.scm (pass-coffin): New variable. Reviewed-by: Steve George <steve@futurile.net> Change-Id: I2fdf6c755b9b75780c5a3c0304e5b961a15640a4 Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index b79fdfc6a0..09be72cfa6 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -39,6 +39,7 @@
;;; Copyright © 2022 ( <paren@disroot.org>
;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Christian Miller <christian.miller@dadoes.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1562,6 +1563,37 @@ therefore you don't need to manage more key or secret. Moreover, you can ask
pass-tomb to automatically close your store after a given time.")
(license license:gpl3+)))
+(define-public pass-coffin
+ (package
+ (name "pass-coffin")
+ (version "1.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ayushnix/pass-coffin")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1486ikwsdjsj74qf949vk47r8mfp2mbbdc3scs8786nnnkhzc89n"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;No tests
+ #:make-flags #~(list (string-append "PREFIX="
+ #$output)
+ (string-append "BASHCOMPDIR="
+ #$output "/etc/bash_completion.d"))
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs (list password-store tar))
+ (home-page "https://github.com/ayushnix/pass-coffin")
+ (synopsis "Pass extension to keep the tree of passwords encrypted")
+ (description
+ "Pass-coffin is a pass extension that hides the password store
+data inside a GPG encrypted file, which we'll call a coffin.")
+ (license license:gpl3)))
+
(define-public xkcdpass
(package
(name "xkcdpass")