summaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authoraltadil <Altadil@protonmail.com>2023-09-11 12:07:41 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 19:33:20 +0300
commitfc0bd1c38d5345abc7132e30af8a1dd8f8edecb4 (patch)
tree2a02155bd41f7ed8a45653471b497187a2186696 /gnu/packages/pantheon.scm
parente34257159dd974d5f1d0fc5e816df75507b40e75 (diff)
downloadguix-patches-fc0bd1c38d5345abc7132e30af8a1dd8f8edecb4.tar
guix-patches-fc0bd1c38d5345abc7132e30af8a1dd8f8edecb4.tar.gz
gnu: Add granite-6.
* gnu/packages/pantheon.scm (granite-6): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 12892db137..273dbbefef 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2023 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2023 altadil <Altadil@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,22 @@ things, it provides complex widgets and convenience functions designed for use
in apps built for the Pantheon desktop.")
(license license:lgpl3+)))
+;; This is required for pantheon apps that have not been ported to GTK4 yet.
+(define-public granite-6
+ (package
+ (inherit granite)
+ (version "6.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/granite")
+ (commit version)))
+ (file-name (git-file-name "granite" version))
+ (sha256
+ (base32
+ "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
+ (propagated-inputs (list glib libgee gtk+))))
+
(define-public pantheon-calculator
(package
(name "pantheon-calculator")