summaryrefslogtreecommitdiff
path: root/gnu/packages/pantheon.scm
diff options
context:
space:
mode:
authoraltadil <Altadil@protonmail.com>2023-09-11 12:07:58 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 19:33:20 +0300
commitf5040becbf0e702a341f528f350409245ee1b881 (patch)
tree06711c6d89a3fd993aebbbbe11a63e178d9f074c /gnu/packages/pantheon.scm
parentfc0bd1c38d5345abc7132e30af8a1dd8f8edecb4 (diff)
downloadguix-patches-f5040becbf0e702a341f528f350409245ee1b881.tar
guix-patches-f5040becbf0e702a341f528f350409245ee1b881.tar.gz
gnu: Add pantheon-terminal.
* gnu/packages/pantheon.scm (pantheon-terminal): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/pantheon.scm')
-rw-r--r--gnu/packages/pantheon.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 273dbbefef..5b83b96801 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -27,11 +27,13 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
#:use-module (gnu packages package-management)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages xml)
#:use-module (gnu packages web)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
#:use-module (guix git-download)
@@ -130,6 +132,57 @@ arithmetic. It is the default calculator application in the Pantheon
desktop.")
(license license:gpl3)))
+(define-public pantheon-terminal
+ (package
+ (name "pantheon-terminal")
+ (version "6.1.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/elementary/terminal")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x3gzghnfx4a1q2zhra4dysc0pm1zvlfdxj96qhfb627pz16iv4k"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f ; Tests invole launching the terminal.
+ #:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-before 'install 'set-environment-variables
+ (lambda _
+ ;; Disable compiling schemas and updating desktop databases
+ (setenv "DESTDIR" "/")))
+ (add-after 'install 'install-symlinks
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out
+ "/bin/io.elementary.terminal"))
+ (link (string-append out "/bin/pantheon-terminal")))
+ (symlink bin link)))))))
+ (native-inputs (list appstream
+ desktop-file-utils ;required for tests
+ gettext-minimal ;for msgfmt
+ `(,glib "bin") ;for glib-compile-resources
+ gobject-introspection
+ pkg-config
+ vala
+ xvfb-run))
+ (inputs (list granite-6
+ gtk+
+ libgee
+ libhandy
+ pcre2
+ vte))
+ (synopsis "Terminal emulator from elementaryOS")
+ (description "pantheon-terminal is a lightweight, beautiful and simple
+terminal. It comes with sane defaults, browser-class tabs, sudo paste
+protection, smart copy/paste, and little to no configuration. It is the default
+terminal in the Pantheon desktop.")
+ (home-page "https://elementary.io/open-source")
+ (license license:lgpl3)))
+
(define-public sideload
(package
(name "sideload")