summaryrefslogtreecommitdiff
path: root/gnu/packages/package-management.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-07-12 14:57:58 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-15 09:57:27 +0100
commitdca96f27ed5b870109c26836d32d991fcfbedaab (patch)
treedc5a74686d96d1ce58cd1cdb00209285086edd0f /gnu/packages/package-management.scm
parent0c1aa354048f82023e6d2043bfecc4fd58bc9b58 (diff)
downloadguix-patches-dca96f27ed5b870109c26836d32d991fcfbedaab.tar
guix-patches-dca96f27ed5b870109c26836d32d991fcfbedaab.tar.gz
gnu: Add bffe.
* gnu/packages/package-management.scm (bffe): New variable.
Diffstat (limited to 'gnu/packages/package-management.scm')
-rw-r--r--gnu/packages/package-management.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 51a5d52131..daf2d3b0c0 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -961,6 +961,59 @@ transactions from C or Python.")
;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
(license license:gpl2+)))
+(define-public bffe
+ (let ((commit "634d3444c094dd594bdf2b15b9a71055462ae676")
+ (revision "1"))
+ (package
+ (name "bffe")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.cbaines.net/guix/bffe")
+ (commit commit)))
+ (sha256
+ (base32
+ "0z13hyaq6bs2j3hnr7ys2vsyx2554zy69ka21savywx0ci3hhfk3"))
+ (file-name (string-append name "-" version "-checkout"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config
+ autoconf
+ automake
+
+ ;; Guile libraries are needed here for cross-compilation.
+ guile-next
+ guile-gnutls
+ guile-json-4
+ guix
+ guix-data-service
+ guix-build-coordinator
+ guile-fibers-1.3
+ guile-prometheus
+ guile-lib))
+ (inputs
+ (list guile-next))
+ (propagated-inputs
+ (list guile-gnutls
+ guile-json-4
+ guix
+ guix-data-service
+ guix-build-coordinator
+ guile-fibers-1.3
+ guile-prometheus
+ guile-lib))
+ (home-page "https://git.cbaines.net/guix/bffe")
+ (synopsis "Build Farm Front-end for Guix")
+ (description
+ "The BFFE of Build Farm Front-end is an experimental frontend for Guix
+build farms. It works together with the Guix Data Service and Guix Build
+Coordinator to submit builds and monitor the activity.
+
+It functions as a Guile library, with the @code{run-bffe-service} procedure in
+the @code{(bffe)} module as the entry point.")
+ (license license:gpl3+))))
+
(define-public python-anaconda-client
(package
(name "python-anaconda-client")