summaryrefslogtreecommitdiff
path: root/gnu/packages/orpheus.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
committerMark H Weaver <mhw@netris.org>2018-01-23 17:01:07 -0500
commita102d359a68ce7219a1880e47dd6f9332cbbce3a (patch)
treed879e718f08d776ad84c456c91a349e59941d1f2 /gnu/packages/orpheus.scm
parent07b8ea841e1e2eda5b367f35cf68d23d0520cc4d (diff)
parentf3a13a21e50fa3751fc39e5768ea6843bfc19df2 (diff)
downloadguix-patches-a102d359a68ce7219a1880e47dd6f9332cbbce3a.tar
guix-patches-a102d359a68ce7219a1880e47dd6f9332cbbce3a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/orpheus.scm')
-rw-r--r--gnu/packages/orpheus.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/orpheus.scm b/gnu/packages/orpheus.scm
index d672ebce75..d981be279c 100644
--- a/gnu/packages/orpheus.scm
+++ b/gnu/packages/orpheus.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2014 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2014, 2018 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,7 +27,8 @@
#:use-module (gnu packages mp3)
#:use-module (gnu packages base)
#:use-module (gnu packages xiph)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (ice-9 match))
(define-public orpheus
(package
@@ -62,13 +63,14 @@
(setenv "CONFIG_SHELL" (which "bash"))
(setenv "SHELL" (which "bash"))
(setenv "LIBS" "-logg") ;doesn't declare its use of libogg
- (zero?
- (system* "./configure" (string-append "--prefix=" out)
- ,@(if (string=? "mips64el-linux"
- (%current-system))
- '("--host=mips64el-unknown-linux-gnu")
- '())
- )))))
+ (invoke "./configure"
+ (string-append "--prefix=" out)
+ ,@(match (%current-system)
+ ("mips64el-linux"
+ '("--host=mips64el-unknown-linux-gnu"))
+ ("aarch64-linux"
+ '("--build=aarch64-unknown-linux-gnu"))
+ (_ `()))))))
(add-after 'configure 'configure-players
(lambda* (#:key inputs #:allow-other-keys)
;; To avoid propagating the mpg321 and vorbis-tools inputs, we can