summaryrefslogtreecommitdiff
path: root/gnu/packages/opencog.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-12-13 16:29:21 -0500
commit6dffced09ecda024e0884e352778c221ad066fd6 (patch)
tree1707e8d8df4d9c47317a39ab6abbfc2ca66a6c29 /gnu/packages/opencog.scm
parentb603554ed044638dd40b6863d5dada59eefe03b8 (diff)
parente3196755e60ba7f1ed9d432e73f26a85e0c8893c (diff)
downloadguix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar
guix-patches-6dffced09ecda024e0884e352778c221ad066fd6.tar.gz
Merge branch 'core-updates-frozen' into 'master'.
At last!
Diffstat (limited to 'gnu/packages/opencog.scm')
-rw-r--r--gnu/packages/opencog.scm31
1 files changed, 10 insertions, 21 deletions
diff --git a/gnu/packages/opencog.scm b/gnu/packages/opencog.scm
index cca0b37ead..998d9b47ae 100644
--- a/gnu/packages/opencog.scm
+++ b/gnu/packages/opencog.scm
@@ -54,7 +54,7 @@
(arguments
`(#:test-target "tests"))
(inputs
- `(("boost" ,boost)))
+ (list boost))
(native-inputs
`(("cxxtest" ,cxxtest)
("python" ,python-minimal)
@@ -93,11 +93,7 @@ utilities use for typical programming tasks in multiple OpenCog projects.")
(assoc-ref %outputs "out")
"/share/guile/site/2.2/"))))
(inputs
- `(("boost" ,boost)
- ("cogutil" ,cogutil)
- ("gmp" ,gmp)
- ("guile" ,guile-2.2)
- ("postgresql" ,postgresql)))
+ (list boost cogutil gmp guile-2.2 postgresql))
(native-inputs
`(("cxxtest" ,cxxtest)
("python" ,python-minimal)
@@ -139,11 +135,7 @@ features not otherwise available.")
(assoc-ref %outputs "out")
"/share/guile/site/2.2/"))))
(inputs
- `(("atomspace" ,atomspace)
- ("boost" ,boost)
- ("cogutil" ,cogutil)
- ("gmp" ,gmp)
- ("guile" ,guile-2.2)))
+ (list atomspace boost cogutil gmp guile-2.2))
(native-inputs
`(("cxxtest" ,cxxtest)
("python" ,python-minimal)
@@ -182,12 +174,12 @@ OpenCog framework.")
(assoc-ref %outputs "out")
"/share/guile/site/2.2/"))))
(inputs
- `(("atomspace" ,atomspace)
- ("boost" ,boost)
- ("cogserver" ,cogserver)
- ("cogutil" ,cogutil)
- ("gmp" ,gmp)
- ("guile" ,guile-2.2)))
+ (list atomspace
+ boost
+ cogserver
+ cogutil
+ gmp
+ guile-2.2))
(native-inputs
`(("cxxtest" ,cxxtest)
("python" ,python-minimal)
@@ -288,10 +280,7 @@ combination.")
"/share/guile/site/2.2/opencog"))))
#t)))))
(inputs
- `(("atomspace" ,atomspace)
- ("cogutil" ,cogutil)
- ("gmp" ,gmp)
- ("guile" ,guile-2.2)))
+ (list atomspace cogutil gmp guile-2.2))
(native-inputs
`(("cxxtest" ,cxxtest)
("python" ,python-minimal)