summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2023-12-25 11:44:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2023-12-30 22:12:18 +0100
commitaed922fcdd68af287eb231b3476d592978ef4cf1 (patch)
tree3414b75269786e45e0ea20e55a9c18906ea643b5 /gnu/packages/ocaml.scm
parent1cef2c561f51acc309060855b963892ebf776c36 (diff)
downloadguix-patches-aed922fcdd68af287eb231b3476d592978ef4cf1.tar
guix-patches-aed922fcdd68af287eb231b3476d592978ef4cf1.tar.gz
gnu: Remove ocaml4.07-migrate-parsetree.
* gnu/packages/ocaml.scm (ocaml4.07-migrate-parsetree): Remove variable. (ocaml-migrate-parsetree)[properties]: Remove variant. Change-Id: Iec470c670517fbb8b1b554c3a357b08972c48853
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 1 insertions, 22 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index cc3e15ff9c..a3c664e62d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1942,34 +1942,13 @@ module of this library is parameterised by the type of S-expressions.")
(arguments `(#:tests? #f))
(propagated-inputs
(list ocaml-ppx-derivers ocamlbuild ocaml-result))
- (properties `((upstream-name . "ocaml-migrate-parsetree")
- (ocaml4.07-variant . ,(delay ocaml4.07-migrate-parsetree))))
+ (properties `((upstream-name . "ocaml-migrate-parsetree")))
(synopsis "OCaml parsetree converter")
(description "This library converts between parsetrees of different OCaml
versions. For each version, there is a snapshot of the parsetree and conversion
functions to the next and/or previous version.")
(license license:lgpl2.1+)))
-;; OCaml 4.07 packages require version 1.*
-(define-public ocaml4.07-migrate-parsetree
- (package-with-ocaml4.07
- (package
- (inherit ocaml-migrate-parsetree)
- (name "ocaml-migrate-parsetree")
- (version "1.8.0")
- (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "16x8sxc4ygxrr1868qpzfqyrvjf3hfxvjzmxmf6ibgglq7ixa2nq"))))
- (properties '((upstream-name . "ocaml-migrate-parsetree"))))))
-
(define-public ocaml-linenoise
(package
(name "ocaml-linenoise")