summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:42 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:51 +0200
commit82f66e98b1f4e92cd1f98c701230a1e63f9c6d48 (patch)
treeef54773e864dec75e0929700ba894de7f9c731f4 /gnu/packages/ocaml.scm
parent831f192346630227e89c87932bab230377989527 (diff)
downloadguix-patches-82f66e98b1f4e92cd1f98c701230a1e63f9c6d48.tar
guix-patches-82f66e98b1f4e92cd1f98c701230a1e63f9c6d48.tar.gz
gnu: ocaml-opam-file-format: Fix reference to output.
* gnu/packages/ocaml.scm (ocaml-opam-file-format)[arguments]<#:make-flags>: Use #$output. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 48950589c5..1e32ebee60 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -761,8 +761,8 @@ let () = String.split_on_char ':' (Sys.getenv \"OCAMLPATH\")
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; No tests
- #:make-flags (list (string-append "LIBDIR=" (assoc-ref %outputs "out")
- "/lib/ocaml/site-lib"))
+ #:make-flags ,#~(list (string-append "LIBDIR=" #$output
+ "/lib/ocaml/site-lib"))
#:phases
(modify-phases %standard-phases
(delete 'configure))))