summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:38:28 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:56 +0100
commitedda7ebec15ad15339b067225efc55207867a5e1 (patch)
tree52dd33ab4ebafafd520bae1b01c5c783c213c174 /gnu/packages/ocaml.scm
parentd2203187feaa0d3c7ebc9c9f1c49cd0788615f01 (diff)
downloadguix-patches-edda7ebec15ad15339b067225efc55207867a5e1.tar
guix-patches-edda7ebec15ad15339b067225efc55207867a5e1.tar.gz
gnu: Add ocaml-ppx-typerep-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-typerep-conv): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a12d198089..ebc5caf254 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2461,3 +2461,24 @@ many values).")
(description "A ppx rewriter for monadic and applicative let bindings,
match expressions, and if expressions.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-typerep-conv
+ (package
+ (name "ocaml-ppx-typerep-conv")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_typerep_conv" version
+ "0g0xqm9s1b2jjvxb8yp69281q2s3bwz6sibn10fvgcdawpa0rmrg"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-tools" ,ocaml-ppx-tools)
+ ("ppx-type-conv" ,ocaml-ppx-type-conv)
+ ("ppx-core" ,ocaml-ppx-core)
+ ("typerep" ,ocaml-typerep)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_typerep_conv")
+ (synopsis "Generation of runtime types from type declarations")
+ (description "Automatic generation of runtime types from type definitions.")
+ (license license:asl2.0)))