summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-03-17 21:19:55 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-17 21:43:13 +1000
commit91df9eaefa371b9bb600f7d1387e6803b5e71904 (patch)
treeb0f3ca3a48c31427c4d26f52185cc40c60cc68b8 /gnu/packages/ocaml.scm
parent0c4dbdc23e07029385abed23af837f67c8a0ffd8 (diff)
downloadguix-patches-91df9eaefa371b9bb600f7d1387e6803b5e71904.tar
guix-patches-91df9eaefa371b9bb600f7d1387e6803b5e71904.tar.gz
gnu: Add ocaml-csv.
* gnu/packages/ocaml.scm (ocaml-csv): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f5001533ff..03c6433b24 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1243,6 +1243,30 @@ coexistence with the old (version 2) SQLite and its OCaml wrapper
@code{ocaml-sqlite}.")
(license license:expat)))
+(define-public ocaml-csv
+ (package
+ (name "ocaml-csv")
+ (version "1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://github.com/Chris00/ocaml-csv/releases/download/"
+ version "/csv-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rv7x843vn6scxj87hzl01yqrl26rc27lr8s7z6rp9vs745g05zj"))))
+ (build-system ocaml-build-system)
+ (home-page "https://github.com/Chris00/ocaml-csv")
+ (synopsis "Pure OCaml functions to read and write CSV")
+ (description
+ "@dfn{Comma separated values} (CSV) is a simple tabular format supported
+by all major spreadsheets. This library implements pure OCaml functions to
+read and write files in this format as well as some convenience functions to
+manipulate such data.")
+ (license (package-license camlp4))))
+
(define-public ocaml-mtime
(package
(name "ocaml-mtime")