summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 19:28:31 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-03-14 22:09:44 +0100
commit651563bd71ba40d35507f42493dd5a6ff9a94077 (patch)
tree72f274b45b1d531e9ac7f3cfde206fffe2a9a459 /gnu/packages/ocaml.scm
parent14af90cfbd864aae8637f3046cf878c5dd4c8778 (diff)
downloadguix-patches-651563bd71ba40d35507f42493dd5a6ff9a94077.tar
guix-patches-651563bd71ba40d35507f42493dd5a6ff9a94077.tar.gz
gnu: Add ocaml-ppx-here.
* gnu/packages/ocaml.scm (ocaml-ppx-here): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 63a7c082a3..fa9fb51155 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2375,3 +2375,22 @@ types")
(description "Generation of accessor and iteration functions for ocaml
variant types.")
(license license:asl2.0)))
+
+(define-public ocaml-ppx-here
+ (package
+ (name "ocaml-ppx-here")
+ (version "113.33.03")
+ (source (janestreet-origin "ppx_here" version
+ "1ay8lfxi0qg3ib2zkwh4h0vqk3gjmxaz572gzab0bbxyqn3z86v7"))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("js-build-tools" ,ocaml-js-build-tools)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("ppx-driver" ,ocaml-ppx-driver)
+ ("ppx-core" ,ocaml-ppx-core)))
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/ppx_here")
+ (synopsis "Expands [%here] into its location")
+ (description "Expands [%here] into its location.")
+ (license license:asl2.0)))