summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 11:09:27 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-04-29 17:51:27 +0200
commit2c6ef0dd3b9076dc96ee9c0c9b492835f824e9bd (patch)
tree2965dea1f0b8c8b9a1c75e21852acf0806074f4b /gnu/packages/ocaml.scm
parent0660d3276c7cb6686f40bd6f3f2488b0b0abb3f6 (diff)
downloadguix-patches-2c6ef0dd3b9076dc96ee9c0c9b492835f824e9bd.tar
guix-patches-2c6ef0dd3b9076dc96ee9c0c9b492835f824e9bd.tar.gz
gnu: Add ocaml-qcheck.
* gnu/packages/ocaml.scm (ocaml-qcheck): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 169e42236f..1a1cef353f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -969,6 +969,29 @@ It provides support for ANSI C syntax, old-C K&R style syntax and the standard
GNU CC attributes. It provides also a C pretty printer as an example of use.")
(license license:lgpl2.1)))
+(define-public ocaml-qcheck
+ (package
+ (name "ocaml-qcheck")
+ (version "0.5.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/c-cube/qcheck/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zs1pg5cb1iry554v3cdmmiglsrwmsqa9x8zxmzb118fnk5d3ha6"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("ounit" ,ocaml-ounit)))
+ (home-page "https://github.com/c-cube/qcheck")
+ (synopsis "QuickCheck inspired property-based testing for OCaml")
+ (description "QuickCheck inspired property-based testing for OCaml. This
+module allows to check invariants (properties of some types) over randomly
+generated instances of the type. It provides combinators for generating
+instances and printing them.")
+ (license license:lgpl3+)))
+
(define-public ocaml-qtest
(package
(name "ocaml-qtest")