summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2017-01-06 21:01:05 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-17 21:19:23 +1000
commit0c4dbdc23e07029385abed23af837f67c8a0ffd8 (patch)
tree0952632464f0a53f319fdd3db4d2d7d3d52b26f6 /gnu/packages/ocaml.scm
parentef71ed8ffa34f8c8b9dd029e262f21bd2eb3db20 (diff)
downloadguix-patches-0c4dbdc23e07029385abed23af837f67c8a0ffd8.tar
guix-patches-0c4dbdc23e07029385abed23af837f67c8a0ffd8.tar.gz
gnu: Add ocaml-sqlite3.
* gnu/packages/ocaml.scm (ocaml-sqlite3): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ebc5caf254..f5001533ff 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages emacs)
#:use-module (gnu packages gcc)
#:use-module (gnu packages ghostscript)
@@ -1213,6 +1214,35 @@ to operate on the result type available from OCaml 4.03 in the standard
library.")
(license license:isc)))
+(define-public ocaml-sqlite3
+ (package
+ (name "ocaml-sqlite3")
+ (version "4.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/mmottl/sqlite3-ocaml/releases/download/v"
+ version "/sqlite3-ocaml-" version ".tar.gz"))
+ (sha256
+ (base32
+ "14c1nir7c6bivajg0vyx853y7la7r5d25g1v5hjb2wfi73r15p1m"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("sqlite" ,sqlite)))
+ (home-page "https://mmottl.github.io/sqlite3-ocaml")
+ (synopsis "SQLite3 Bindings for OCaml")
+ (description
+ "SQLite3-OCaml is an OCaml library with bindings to the SQLite3 client
+API. Sqlite3 is a self-contained, serverless, zero-configuration,
+transactional SQL database engine with outstanding performance for many use
+cases. These bindings are written in a way that enables a friendly
+coexistence with the old (version 2) SQLite and its OCaml wrapper
+@code{ocaml-sqlite}.")
+ (license license:expat)))
+
(define-public ocaml-mtime
(package
(name "ocaml-mtime")