summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-04 17:08:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-04 17:08:31 +0200
commitd648037edc2c9355a99becd6f5b71f9ae392ac4f (patch)
tree787516601b6b5b10c3362ec0fff97377aa90f83c /gnu/packages/ocaml.scm
parent1aceb93a6f1f7f1e76e23ec2a2d033871f764272 (diff)
downloadguix-patches-d648037edc2c9355a99becd6f5b71f9ae392ac4f.tar
guix-patches-d648037edc2c9355a99becd6f5b71f9ae392ac4f.tar.gz
gnu: ocaml-biniou: Simplify "make-writable" phase.
* gnu/packages/ocaml.scm (ocaml-biniou)[arguments]: Simplify phase.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index bf9242410d..bb42003de2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4477,12 +4477,7 @@ than the first one.")
`(#:phases
(modify-phases %standard-phases
(add-before 'build 'make-writable
- (lambda _
- (for-each
- (lambda (file)
- (chmod file #o644))
- (find-files "." "."))
- #t)))))
+ (lambda _ (for-each make-file-writable (find-files "." ".")))))))
(inputs
`(("ocaml-easy-format" ,ocaml-easy-format)))
(native-inputs