summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-01-05 17:38:15 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-01-16 20:08:33 +0100
commitac06a773f5c93cf2b59d15150a1a912bd0320479 (patch)
tree0922f5d889a0ba780a6d83d42c542b850d18ef3c /gnu/packages/ocaml.scm
parent22074259d2f9550267c65102a348b0efd1f31d88 (diff)
downloadguix-patches-ac06a773f5c93cf2b59d15150a1a912bd0320479.tar
guix-patches-ac06a773f5c93cf2b59d15150a1a912bd0320479.tar.gz
gnu: Add ocaml-compiler-libs.
* gnu/packages/ocaml.scm (ocaml-compiler-libs): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7f54553ed7..4cda0ccd2a 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5002,3 +5002,27 @@ features such as I/O are not offered by Base. They are instead
provided by companion libraries such as
@url{https://github.com/janestreet/stdio, ocaml-stdio}.")
(license license:expat)))
+
+(define-public ocaml-compiler-libs
+ (package
+ (name "ocaml-compiler-libs")
+ (version "0.11.0")
+ (home-page "https://github.com/janestreet/ocaml-compiler-libs")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "03jds7bszh8wwpfwxb3dg0gyr1j1872wxwx1xqhry5ir0i84bg0s"))))
+ (build-system dune-build-system)
+ (arguments
+ '(#:tests? #f)) ;no tests
+ (synopsis "Compiler libraries repackaged")
+ (description "This packaeg simply repackages the OCaml compiler libraries
+so they don't expose everything at toplevel. For instance, @code{Ast_helper}
+is now @code{Ocaml_common.Ast_helper}.")
+ (license license:expat)))