summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:46 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:10 +0200
commita18414adc42cb728afda4dfb3ed8d971ce750db3 (patch)
tree6312d90a4e49596f06b27b90472d31c8f4c357b7 /gnu/packages/ocaml.scm
parentd9f0685dea2ffc21167d80f409c3ea6088f9c7de (diff)
downloadguix-patches-a18414adc42cb728afda4dfb3ed8d971ce750db3.tar
guix-patches-a18414adc42cb728afda4dfb3ed8d971ce750db3.tar.gz
gnu: Add ocaml-ppx-typerep-conv.
* gnu/packages/ocaml.scm (ocaml-ppx-typerep-conv): New variable. (ocaml4.07-ppx-typerep-conv): Inherit from it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm60
1 files changed, 36 insertions, 24 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8c464147f5..8ec5953730 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6203,37 +6203,49 @@ packages.")
"0z3fc55jdjhhsblla6z4fqc13kljpcz29q79rvs5h2vsraqrldr2"))
(properties `((upstream-name . "ppx_js_style"))))))
-(define-public ocaml4.07-ppx-typerep-conv
+(define-public ocaml-ppx-typerep-conv
(package
- (name "ocaml4.07-ppx-typerep-conv")
- (version "0.11.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/janestreet/ppx_typerep_conv")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0a13dpfrrg0rsm8qni1bh7pqcda30l70z8r6yzi5a64bmwk7g5ah"))))
+ (name "ocaml-ppx-typerep-conv")
+ (version "0.14.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_typerep_conv/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0yk9vkpnwr8labgfncqdi4rfkj88d8mb3cr8m4gdqpi3f2r27hf0"))))
(build-system dune-build-system)
(arguments
- `(#:test-target "."
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-typerep" ,ocaml4.07-typerep)
- ("ocaml-migrate-parsetree"
- ,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
- (properties `((upstream-name . "ppx_typerep_conv")))
+ `(#:test-target "."))
+ (propagated-inputs (list ocaml-base ocaml-typerep ocaml-ppxlib))
+ (properties `((upstream-name . "ppx_typerep_conv")
+ (ocaml4.07-variant . ,(delay ocaml4.07-ppx-typerep-conv))))
(home-page "https://github.com/janestreet/ppx_typerep_conv")
(synopsis "Generation of runtime types from type declarations")
(description "This package can automatically generate runtime types
from type definitions.")
- (license license:asl2.0)))
+ (license license:expat)))
+
+(define-public ocaml4.07-ppx-typerep-conv
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-ppx-typerep-conv)
+ (version "0.11.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_typerep_conv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "ocaml4.07-ppx-typerep-conv" version))
+ (sha256
+ (base32
+ "0a13dpfrrg0rsm8qni1bh7pqcda30l70z8r6yzi5a64bmwk7g5ah"))))
+ (properties '())
+ (propagated-inputs
+ (list ocaml-base ocaml-typerep ocaml-migrate-parsetree ocaml-ppxlib))
+ (license license:asl2.0))))
(define-public ocaml-ppx-base
(package