summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:23 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-13 17:15:51 +0200
commitfac530bca6603b27e59c3cb2dfa47b99948e62f9 (patch)
tree28f8574e167a192b4b6bc75a0fbde16029d570f7 /gnu/packages/ocaml.scm
parent10ca41419702c72129f3f9ae9544fa45ea275da7 (diff)
downloadguix-patches-fac530bca6603b27e59c3cb2dfa47b99948e62f9.tar
guix-patches-fac530bca6603b27e59c3cb2dfa47b99948e62f9.tar.gz
gnu: Add ocaml-ppx-expect.
* gnu/packages/ocaml.scm (ocaml-ppx-expect): New variable. (ocaml4.07-ppx-expect): Inherit from ocaml-ppx-expect. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm83
1 files changed, 49 insertions, 34 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 17347243f6..a736eb3a75 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3803,7 +3803,7 @@ library is currently designed for Unicode Standard 3.2.")
`(("ocaml-result" ,(package-with-ocaml4.07 ocaml-result))
("ocaml-camomile" ,(package-with-ocaml4.07 ocaml-camomile))))
(native-inputs
- `(("ocaml-ppx-expect" ,ocaml4.07-ppx-expect)))
+ `(("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))))
(properties
`((upstream-name . "charInfo_width")))
(home-page "https://bitbucket.org/zandoye/charinfo_width/")
@@ -5888,40 +5888,31 @@ useful errors on failure.")
("ocaml-ppxlib" ,ocaml-ppxlib)))
(properties `((upstream-name . "ppx_assert"))))))
-(define-public ocaml4.07-ppx-expect
+(define-public ocaml-ppx-expect
(package
- (name "ocaml4.07-ppx-expect")
- (version "0.12.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/janestreet/ppx_expect")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1wawsbjfkri4sw52n8xqrzihxc3xfpdicv3ahz83a1rsn4lb8j5q"))))
+ (name "ocaml-ppx-expect")
+ (version "0.14.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_expect")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vbbnjrzpyk5p0js21lafr6fcp2wqka89p1876rdf472cmg0l7fv"))))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-ppx-assert" ,(package-with-ocaml4.07 ocaml4.07-ppx-assert))
- ("ocaml-ppx-compare" ,(package-with-ocaml4.07 ocaml-ppx-compare))
- ("ocaml-ppx-custom-printf" ,(package-with-ocaml4.07 ocaml-ppx-custom-printf))
- ("ocaml-ppx-fields-conv" ,(package-with-ocaml4.07 ocaml-ppx-fields-conv))
- ("ocaml-ppx-here" ,(package-with-ocaml4.07 ocaml-ppx-here))
- ("ocaml-ppx-inline-test" ,(package-with-ocaml4.07 ocaml-ppx-inline-test))
- ("ocaml-ppx-sexp-conv" ,(package-with-ocaml4.07 ocaml-ppx-sexp-conv))
- ("ocaml-ppx-variants-conv" ,(package-with-ocaml4.07 ocaml-ppx-variants-conv))
- ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))
- ("ocaml-migrate-parsetree"
- ,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))
- ("ocaml-re" ,(package-with-ocaml4.07 ocaml-re))))
- (properties `((upstream-name . "ppx_expect")))
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-re" ,ocaml-re)))
+ (properties `((upstream-name . "ppx_expect")
+ (ocaml4.07-variant . ,(delay ocaml4.07-ppx-expect))))
(home-page "https://github.com/janestreet/ppx_expect")
(synopsis "Cram like framework for OCaml")
(description "Expect-test is a framework for writing tests in OCaml, similar
@@ -5931,6 +5922,30 @@ output-generating code, interleaved with @code{%expect} extension expressions
to denote the expected output.")
(license license:asl2.0)))
+(define-public ocaml4.07-ppx-expect
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-ppx-expect)
+ (version "0.12.0")
+ (source
+ (janestreet-origin "ppx_expect" version
+ "1zpci8c49yn2ixchmwjx1kf9pwybv3dnn4l2dgnd6m36qnkralfk"))
+ (propagated-inputs
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-ppx-assert" ,ocaml-ppx-assert)
+ ("ocaml-ppx-compare" ,ocaml-ppx-compare)
+ ("ocaml-ppx-custom-printf" ,ocaml-ppx-custom-printf)
+ ("ocaml-ppx-fields-conv" ,ocaml-ppx-fields-conv)
+ ("ocaml-ppx-here" ,ocaml-ppx-here)
+ ("ocaml-ppx-inline-test" ,ocaml-ppx-inline-test)
+ ("ocaml-ppx-sexp-conv" ,ocaml-ppx-sexp-conv)
+ ("ocaml-ppx-variants-conv" ,ocaml-ppx-variants-conv)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)
+ ("ocaml-re" ,ocaml-re)))
+ (properties `((upstream-name . "ppx_expect"))))))
+
(define-public ocaml-ppx-js-style
(package
(name "ocaml-ppx-js-style")
@@ -6103,7 +6118,7 @@ functions from type definitions.")
("ocaml-ppx-bench" ,ocaml4.07-ppx-bench)
("ocaml-ppx-bin-prot" ,ocaml4.07-ppx-bin-prot)
("ocaml-ppx-custom-printf" ,(package-with-ocaml4.07 ocaml-ppx-custom-printf))
- ("ocaml-ppx-expect" ,ocaml4.07-ppx-expect)
+ ("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))
("ocaml-ppx-fail" ,ocaml4.07-ppx-fail)
("ocaml-ppx-fields-conv" ,(package-with-ocaml4.07 ocaml-ppx-fields-conv))
("ocaml-ppx-here" ,(package-with-ocaml4.07 ocaml-ppx-here))
@@ -6248,7 +6263,7 @@ Configurator allows one to:
#:findlib ,ocaml4.07-findlib
#:dune ,ocaml4.07-dune))
(native-inputs
- `(("ocaml-ppx-expect" ,ocaml4.07-ppx-expect)))
+ `(("ocaml-ppx-expect" ,(package-with-ocaml4.07 ocaml-ppx-expect))))
(home-page "https://github.com/janestreet/spawn")
(synopsis "Spawning sub-processes")
(description