summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-21 12:01:56 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-08-08 22:21:23 +0200
commit882976d44495910120bbd3514a39f3d75a38176b (patch)
treee40f22fef0b302451a2d69de25721891a392c409 /gnu/packages/ocaml.scm
parente473fe1056a8b8089715dff46050355f777ef5ed (diff)
downloadguix-patches-882976d44495910120bbd3514a39f3d75a38176b.tar
guix-patches-882976d44495910120bbd3514a39f3d75a38176b.tar.gz
gnu: Add ocaml-uucd.
* gnu/packages/ocaml.scm (ocaml-uucd): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f9380ed228..022531a3a4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6958,6 +6958,39 @@ provides support to program with time varying values: declarative events and
client chooses the concrete timeline.")
(license license:lgpl2.1+)))
+(define-public ocaml-uucd
+ (package
+ (name "ocaml-uucd")
+ (version "13.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://erratique.ch/software/uucd/releases/"
+ "uucd-" version ".tbz"))
+ (sha256
+ (base32
+ "1fg77hg4ibidkv1x8hhzl8z3rzmyymn8m4i35jrdibb8adigi8v2"))))
+ (build-system ocaml-build-system)
+ (arguments
+ '(#:build-flags '("build" "--tests" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (propagated-inputs
+ `(("ocaml-xmlm" ,ocaml-xmlm)))
+ (native-inputs
+ `(("opam" ,opam)
+ ("ocaml-findlib" ,ocaml-findlib)
+ ("ocamlbuild" ,ocamlbuild)
+ ("ocaml-topkg" ,ocaml-topkg)))
+ (home-page "https://erratique.ch/software/uucd")
+ (synopsis "Unicode character database decoder for OCaml")
+ (description "Uucd is an OCaml module to decode the data of the Unicode
+character database from its XML representation. It provides high-level (but
+not necessarily efficient) access to the data so that efficient
+representations can be extracted.")
+ (license license:isc)))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")