summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:45 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:51 +0200
commit463deeefdcba3b10c76df723fb10f2230367bfc6 (patch)
treec480f5180d34be496fb047d0285313a663c3cb5b /gnu/packages/ocaml.scm
parentce8c675a18b2af4659c8b88aaa004882d168aed0 (diff)
downloadguix-patches-463deeefdcba3b10c76df723fb10f2230367bfc6.tar
guix-patches-463deeefdcba3b10c76df723fb10f2230367bfc6.tar.gz
gnu: ocaml-frontc: Fix reference to output.
* gnu/packages/ocaml.scm (ocaml-frontc)[arguments]<#:make-flags>: Use #$output. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 81e967cd34..6fe8cb46f9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1498,9 +1498,8 @@ archive(byte) = \"frontc.cma\"
archive(native) = \"frontc.cmxa\""))))
(symlink (string-append out "/lib/ocaml/frontc")
(string-append out "/lib/ocaml/FrontC"))))))
- #:make-flags (list (string-append "PREFIX="
- (assoc-ref %outputs "out"))
- "OCAML_SITE=$(LIB_DIR)/ocaml/")))
+ #:make-flags ,#~(list (string-append "PREFIX=" #$output)
+ "OCAML_SITE=$(LIB_DIR)/ocaml/")))
(properties `((upstream-name . "FrontC")))
(home-page "https://www.irit.fr/FrontC")
(synopsis "C parser and lexer library")