summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-06-21 12:02:03 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-08-08 22:37:34 +0200
commit092b65e1aa7dca24f89fa8bccd0eb4e5dc07b346 (patch)
tree5ac7a52b7cc63e7e17e43f12932e627e93375a89 /gnu/packages/ocaml.scm
parent03f05b475badce7440448e6b1bc60e2e51e885b6 (diff)
downloadguix-patches-092b65e1aa7dca24f89fa8bccd0eb4e5dc07b346.tar
guix-patches-092b65e1aa7dca24f89fa8bccd0eb4e5dc07b346.tar.gz
gnu: Add ocaml-dune-build-info.
* gnu/packages/ocaml.scm (ocaml-dune-build-info): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 92c00801a4..76fb53db01 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -7086,6 +7086,24 @@ representation.")
that involve memoization and recursion.")
(license license:lgpl2.0)))
+(define-public ocaml-dune-build-info
+ (package
+ (inherit dune)
+ (name "ocaml-dune-build-info")
+ (build-system dune-build-system)
+ (arguments
+ '(#:package "dune-build-info"
+ ;; No separate test suite from dune.
+ #:tests? #f))
+ (propagated-inputs
+ `(("ocaml-odoc" ,ocaml-odoc)))
+ (synopsis "Embed build informations inside executable")
+ (description "This package allows one to access information about how the
+executable was built, such as the version of the project at which it was built
+or the list of statically linked libraries with their versions. It supports
+reporting the version from the version control system during development to
+get an precise reference of when the executable was built.")))
+
(define-public ocaml-bigstringaf
(package
(name "ocaml-bigstringaf")