summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:45 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:07 +0200
commitd9f0685dea2ffc21167d80f409c3ea6088f9c7de (patch)
treec0da47ed29cd25475d981395a15ef88d502e8da2 /gnu/packages/ocaml.scm
parent36e0e198feac247d3ed69996b1ffb254ec6a019b (diff)
downloadguix-patches-d9f0685dea2ffc21167d80f409c3ea6088f9c7de.tar
guix-patches-d9f0685dea2ffc21167d80f409c3ea6088f9c7de.tar.gz
gnu: Add ocaml-typerep.
* gnu/packages/ocaml.scm (ocaml-typerep): New variable. (ocaml4.07-typerep): Inherit from it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm50
1 files changed, 32 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 6690fab76d..8c464147f5 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5786,29 +5786,43 @@ many values).")
"0wxcak3ay4jpigm3pfdcpr65qw4hxfa8whhkryhcd8gy71x056z5"))
(properties `((upstream-name . "ppx_here"))))))
-(define-public ocaml4.07-typerep
+(define-public ocaml-typerep
(package
- (name "ocaml4.07-typerep")
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/typerep-v" version ".tar.gz"))
- (sha256
- (base32
- "1zi7hy0prpgzqhr4lkacr04wvlvbp21jfbdfvffhrm6cd400rb5v"))))
+ (name "ocaml-typerep")
+ (version "0.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/typerep")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wc7h853ka3s3lxxgm61ypidl0lzgc9abdkil6f72anl0c417y90"))))
(build-system dune-build-system)
- (arguments
- `(#:tests? #f
- #:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (propagated-inputs `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))))
+ (arguments `(#:tests? #f)); no tests
+ (propagated-inputs (list ocaml-base))
+ (properties `((ocaml4.07-variant . ,(delay ocaml4.07-typerep))))
(home-page "https://github.com/janestreet/typerep")
(synopsis "Typerep is a library for runtime types")
(description "Typerep is a library for runtime types.")
- (license license:asl2.0)))
+ (license license:expat)))
+
+(define-public ocaml4.07-typerep
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-typerep)
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/typerep-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1zi7hy0prpgzqhr4lkacr04wvlvbp21jfbdfvffhrm6cd400rb5v"))))
+ (properties '())
+ (license license:asl2.0))))
(define-public ocaml4.07-ppx-sexp-value
(package