summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-04-08 15:22:59 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 11:56:39 +0200
commite487d5666a7e0fc0860e94eb6f6bdd06d4e8b537 (patch)
treeb83789a9ec64e3319856021690a91cab6812cbd8 /gnu/packages/ocaml.scm
parent49a106f14e7c7db60643125b972d4634ca5647f1 (diff)
downloadguix-patches-e487d5666a7e0fc0860e94eb6f6bdd06d4e8b537.tar
guix-patches-e487d5666a7e0fc0860e94eb6f6bdd06d4e8b537.tar.gz
gnu: Add ocaml-ppx-fail.
* gnu/packages/ocaml.scm (ocaml-ppx-fail): New variable. (ocaml4.07-ppx-fail): Inherit from it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm57
1 files changed, 34 insertions, 23 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index a57ec2b05f..1c81f2de1c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6139,35 +6139,46 @@ match expressions, and if expressions.")
(properties `((upstream-name . "ppx_let"))))))
-(define-public ocaml4.07-ppx-fail
+(define-public ocaml-ppx-fail
(package
- (name "ocaml4.07-ppx-fail")
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/ppx_fail-v" version ".tar.gz"))
- (sha256
- (base32
- "07plqsvljiwvngggfypwq55g46s5my55y45mvlmalrxyppzr03s8"))))
+ (name "ocaml-ppx-fail")
+ (version "0.14.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/ppx_fail")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "012p9gv7w4sk3b4x0sdmqrmr2856w8xc424waxb6vrybid7qjs95"))))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
- (propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-ppx-here" ,(package-with-ocaml4.07 ocaml-ppx-here))
- ("ocaml-migrate-parsetree"
- ,(package-with-ocaml4.07 ocaml-migrate-parsetree))
- ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
- (properties `((upstream-name . "ppx_fail")))
+ (propagated-inputs (list ocaml-base ocaml-ppx-here ocaml-ppxlib))
+ (properties `((upstream-name . "ppx_fail")
+ (ocaml4.07-variant . ,(delay ocaml4.07-ppx-fail))))
(home-page "https://github.com/janestreet/ppx_fail")
(synopsis "Add location to calls to failwiths")
(description "Syntax extension that makes [failwiths] always include a
position.")
- (license license:asl2.0)))
+ (license license:expat)))
+
+(define-public ocaml4.07-ppx-fail
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-ppx-fail)
+ (version "0.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+ (version-major+minor version)
+ "/files/ppx_fail-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "07plqsvljiwvngggfypwq55g46s5my55y45mvlmalrxyppzr03s8"))))
+ (propagated-inputs
+ (list ocaml-base ocaml-ppx-here ocaml-migrate-parsetree ocaml-ppxlib))
+ (properties '())
+ (license license:asl2.0))))
(define-public ocaml-ppx-cold
(package