summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commit55f9f9b081804c69df49e9689975cf8758e8b0a1 (patch)
treea791c3c8c09c5aa7da7de44c2d0696aa500af02d /gnu/packages/ocaml.scm
parent677a88e075e66bae1eca285a4da7d57b8179b62e (diff)
downloadguix-patches-55f9f9b081804c69df49e9689975cf8758e8b0a1.tar
guix-patches-55f9f9b081804c69df49e9689975cf8758e8b0a1.tar.gz
gnu: ocaml-jbuilder: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml-jbuilder)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5501d16093..d4ff8649a9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4333,15 +4333,15 @@ library is currently designed for Unicode Standard 3.2.")
(package
(name "ocaml-jbuilder")
(version "1.0+beta16")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/janestreet/jbuilder/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1cy07pwvbrlysszs938yd74yyvvbgkffpb82qrjph77zf0h2gdi7"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/janestreet/jbuilder.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y3fgf570w3vrnhianrg26jy5j749zczq3f78s2dy5ylbp1hrx71"))))
(build-system ocaml-build-system)
(arguments
`(#:ocaml ,ocaml-4.02