summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-11-20 15:49:10 +0100
committerDavid Craven <david@craven.ch>2016-12-10 21:47:08 +0100
commite31b75f22f777f8709b9a51c85d97e89146fe43e (patch)
tree4b94efd52a624e9938e421c78ef605218fceae0b /gnu/packages/ocaml.scm
parent2694d1dc80f174f30b49117192f258e32fe6957b (diff)
downloadguix-patches-e31b75f22f777f8709b9a51c85d97e89146fe43e.tar
guix-patches-e31b75f22f777f8709b9a51c85d97e89146fe43e.tar.gz
gnu: Add ocaml-menhir.
* gnu/packages/ocaml.scm (ocaml-menhir): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 84bce3dd37..61d51074e7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -454,6 +454,42 @@ assistant to write formal mathematical proofs using a variety of theorem
provers.")
(license gpl2+)))
+(define-public ocaml-menhir
+ (package
+ (name "ocaml-menhir")
+ (version "20161115")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://gallium.inria.fr/~fpottier/menhir/"
+ "menhir-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j8nmcj2gq6hyyi16z27amiahplgrnk4ppchpm0v4qy80kwkf47k"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("ocaml" ,ocaml)))
+ (arguments
+ `(#:parallel-build? #f ; Parallel build causes failure
+ #:tests? #f ; No check target
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "PREFIX" out))
+ #t)))))
+ (home-page "http://gallium.inria.fr/~fpottier/menhir")
+ (synopsis "Parser generator")
+ (description "Menhir is a parser generator. It turns high-level grammar
+specifications, decorated with semantic actions expressed in the OCaml
+programming language into parsers, again expressed in OCaml. It is based on
+Knuth’s LR(1) parser construction technique.")
+ ;; The file src/standard.mly and all files listed in src/mnehirLib.mlpack
+ ;; that have an *.ml or *.mli extension are GPL licensed. All other files
+ ;; are QPL licensed.
+ (license (list gpl2+ qpl))))
+
(define-public lablgtk
(package
(name "lablgtk")