summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:45:15 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-16 22:34:36 +0100
commitbeeb2d419b23d941c58c5a653ab9fe5c14247cef (patch)
tree4934948a49efe6fc046cc40ba0a07b211d071dd2 /gnu/packages/ocaml.scm
parent8fe6b9327d3598ae5fe5c0f71895f1fdb37c0516 (diff)
downloadguix-patches-beeb2d419b23d941c58c5a653ab9fe5c14247cef.tar
guix-patches-beeb2d419b23d941c58c5a653ab9fe5c14247cef.tar.gz
gnu: Add ocaml-fmt.
* gnu/packages/ocaml.scm (ocaml-fmt): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f8609bdc9e..ace8424a9d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1227,3 +1227,31 @@ module automatically handles syntax errors, help messages and UNIX man page
generation. It supports programs with single or multiple commands and respects
most of the POSIX and GNU conventions.")
(license license:bsd-3)))
+
+(define-public ocaml-fmt
+ (package
+ (name "ocaml-fmt")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/fmt/releases/fmt-"
+ version ".tbz"))
+ (sha256 (base32
+ "16y7ibndnairb53j8a6qgipyqwjxncn4pl9jiw5bxjfjm59108px"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("opam" ,opam)
+ ("topkg" ,ocaml-topkg)))
+ (propagated-inputs `(("result" ,ocaml-result)
+ ("cmdliner" ,ocaml-cmdliner)))
+ (arguments `(#:tests? #f
+ #:build-flags (list "build" "--with-base-unix" "true"
+ "--with-cmdliner" "true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/fmt")
+ (synopsis "OCaml Format pretty-printer combinators")
+ (description "Fmt exposes combinators to devise Format pretty-printing
+functions.")
+ (license license:isc)))