summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-22 20:19:00 +0100
committerDavid Craven <david@craven.ch>2017-01-04 16:04:51 +0100
commit7a76b4afd0ce296bb462be8cf66234e41672c285 (patch)
tree43a54c8d69f3b49e08d375da15c7252b525f9f11 /gnu/packages/ocaml.scm
parentad3d730e3a6ef592f62578d1f40796272e2ea3ec (diff)
downloadguix-patches-7a76b4afd0ce296bb462be8cf66234e41672c285.tar
guix-patches-7a76b4afd0ce296bb462be8cf66234e41672c285.tar.gz
gnu: Add ocaml-ounit.
* gnu/packages/ocaml.scm (ocaml-ounit): New variable. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b3e3bc74ae..f976544f0b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -42,8 +42,10 @@
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages version-control)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix build-system gnu)
+ #:use-module (guix build-system ocaml)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
@@ -756,3 +758,25 @@ allows the user to enter queries on the command-line. In order to simplify
compilation and linkage, there are new frontends of the various OCaml
compilers that can directly deal with packages.")
(license license:x11)))
+
+;; note that some tests may hang for no obvious reason.
+(define-public ocaml-ounit
+ (package
+ (name "ocaml-ounit")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri "ounit" version 1258))
+ (sha256
+ (base32
+ "118xsadrx84pif9vaq13hv4yh22w9kmr0ypvhrs0viir1jr0ajjd"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("libxml2" ,libxml2))) ; for xmllint
+ (arguments
+ `(#:tests? #f)) ; tests are done during build
+ (home-page "http://ounit.forge.ocamlcore.org")
+ (synopsis "Unit testing framework for OCaml")
+ (description "Unit testing framework for OCaml. It is similar to JUnit and
+other XUnit testing frameworks.")
+ (license license:expat)))