summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authordivoplade <d@divoplade.fr>2021-06-01 20:23:20 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-13 17:15:45 +0200
commit61c7467745de89ca431897daf1c541e41dc35fa7 (patch)
tree94c71826ea1fc34241f550963ea54a5d4e6944b9 /gnu/packages/ocaml.scm
parent40d6c7aada5e07e352a81adc9b4004fb22f39d8a (diff)
downloadguix-patches-61c7467745de89ca431897daf1c541e41dc35fa7.tar
guix-patches-61c7467745de89ca431897daf1c541e41dc35fa7.tar.gz
gnu: Add ocaml-graphics.
* gnu/packages/ocaml.scm (ocaml-graphics): New variable. Co-Authored-By: pukkamustard <pukkamustard@posteo.net> Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 13ebafdd01..a7c8436dac 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -6912,3 +6912,29 @@ Both interfaces give the user total control over the blocking behavior of
their application, with the unbuffered interface enabling zero-copy IO.
Parsers are backtracking by default and support unbounded lookahead.")
(license license:bsd-3)))
+
+(define-public ocaml-graphics
+ (package
+ (name "ocaml-graphics")
+ (version "5.1.1")
+ (home-page "https://github.com/ocaml/graphics")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14w07ydji2nbdk366nfp2pzs9484xp9vqv63n345id13v48z8bfi"))))
+ (build-system dune-build-system)
+ (propagated-inputs
+ `(("libx11" ,libx11)))
+ (synopsis "The OCaml graphics library")
+ (description
+ "The graphics library provides a set of portable drawing primitives.
+Drawing takes place in a separate window that is created when
+Graphics.open_graph is called. This library used to be distributed with OCaml
+up to OCaml 4.08.")
+ (license license:lgpl2.1+)))