summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorPeter Kreye <kreyepr@gmail.com>2018-01-13 05:26:37 -0600
committerJulien Lepiller <julien@lepiller.eu>2018-02-01 23:09:23 +0100
commita9e9fd15068ee7901c905a1a9bff14ecf50f2ad0 (patch)
tree16097e6235cd2184b16e444225f50f3771e20efb /gnu/packages/ocaml.scm
parentc98c82370462f8c06c420175dcc47fc1a64cf68d (diff)
downloadguix-patches-a9e9fd15068ee7901c905a1a9bff14ecf50f2ad0.tar
guix-patches-a9e9fd15068ee7901c905a1a9bff14ecf50f2ad0.tar.gz
gnu: Add ocaml-tsdl.
* gnu/packages/ocaml.scm (ocaml-tsdl): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1ecd9ab540..64031dfbbb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages protobuf)
#:use-module (gnu packages python)
+ #:use-module (gnu packages sdl)
#:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
@@ -3843,6 +3844,41 @@ repeat over, over, over and over again if you are using ocamlbuild to build
OCaml projects that contain C stubs.")
(license license:isc)))
+(define-public ocaml-tsdl
+ (package
+ (name "ocaml-tsdl")
+ (version "0.9.1")
+ (home-page "http://erratique.ch/software/tsdl")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append home-page "/releases/tsdl-"
+ version ".tbz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08bb97fhvz829fb0sgjn2p20mp7b04v98zy2qxpk2w390a6c4b34"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:build-flags '("build")
+ #:tests? #f; tests require a display device
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("opam" ,opam)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("findlib" ,ocaml-findlib-1.7.3)
+ ("topkg" ,ocaml-topkg)
+ ("result" ,ocaml-result)
+ ("sdl2" ,sdl2)
+ ("integers" ,ocaml-integers)
+ ("ctypes" ,ocaml-ctypes)))
+ (synopsis "Thin bindings to SDL for OCaml")
+ (description "Tsdl is an OCaml library providing thin bindings to the
+cross-platform SDL C library.")
+ (license license:isc)))
+
(define-public coq-flocq
(package
(name "coq-flocq")