summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorPeter Kreye <kreyepr@gmail.com>2017-10-27 18:33:25 -0500
committerLudovic Courtès <ludo@gnu.org>2017-10-28 10:33:46 +0200
commit50856b7342a331c60db1dbd43262f3f10310607b (patch)
tree71d787a603333af566e11757250782a65e2eefb7 /gnu/packages/ocaml.scm
parente88ff71c10135615a65679f4d2f2de8f36f1308e (diff)
downloadguix-patches-50856b7342a331c60db1dbd43262f3f10310607b.tar
guix-patches-50856b7342a331c60db1dbd43262f3f10310607b.tar.gz
gnu: Add ocaml-findlib-1.7.3.
* gnu/packages/ocaml.scm (ocaml-findlib-1.7.3): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 712cc91e00..1b56670be1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -897,6 +897,28 @@ compilation and linkage, there are new frontends of the various OCaml
compilers that can directly deal with packages.")
(license license:x11)))
+(define-public ocaml-findlib-1.7.3
+ (package
+ (inherit ocaml-findlib)
+ (version "1.7.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.camlcity.org/download/"
+ "findlib" "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12xx8si1qv3xz90qsrpazjjk4lc1989fzm97rsmc4diwla7n15ni"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments ocaml-findlib)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (zero? (system* "make" "install"
+ (string-append "OCAML_CORE_STDLIB="
+ out))))))))))))
+
(define-public ocaml4.01-findlib
(package
(inherit ocaml-findlib)