summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:10:10 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:43 +0200
commite31ee74d911b96a608fceaaeb338324851d350e4 (patch)
tree6155a44d56b914e1f510662ae8c777884e0fd5c3 /gnu/packages/ocaml.scm
parent52485163f3ccb65e46f9ae1929aa380e6abfd3aa (diff)
downloadguix-patches-e31ee74d911b96a608fceaaeb338324851d350e4.tar
guix-patches-e31ee74d911b96a608fceaaeb338324851d350e4.tar.gz
gnu: Add ocaml-async-kernel.
* gnu/packages/ocaml.scm (ocaml-async-kernel): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b7adc6e560..d526b825c4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2939,3 +2939,23 @@ the expected output.")
Core_kernel is the system-independent part of Core. It is aimed for cases when
the full Core is not available, such as in Javascript.")
(license license:asl2.0)))
+
+(define-public ocaml-async-kernel
+ (package
+ (name "ocaml-async-kernel")
+ (version "113.33.03")
+ (source (janestreet-origin "async_kernel" version
+ "04bjsaa23j831r09r38x6xx9nhryvp0z5ihickvhxqa4fb2snyvd"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("core-kernel" ,ocaml-core-kernel)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/async_kernel/")
+ (synopsis "Monadic concurrency library")
+ (description "Async-kernel is a library for concurrent programming in OCaml.")
+ (license license:asl2.0)))