summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:39:42 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:35:23 +0100
commitc590f1ae8a2a9c118f3cdb58fec98be934ccb7dd (patch)
tree4fed07e15eaef4d5f2c38a4021d964a876e7eab6 /gnu/packages/ocaml.scm
parent5d08f98d3e9253037a82522940a5a1496bc69b74 (diff)
downloadguix-patches-c590f1ae8a2a9c118f3cdb58fec98be934ccb7dd.tar
guix-patches-c590f1ae8a2a9c118f3cdb58fec98be934ccb7dd.tar.gz
gnu: Add ocamlify.
* gnu/packages/ocaml.scm (ocamlify): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0128337663..e0412803cc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1728,3 +1728,27 @@ multitude of other network protocols (FTP/SMTP/RTSP/etc).")
that represent binary data in an ASCII string format by translating it into a
radix-64 representation. It is specified in RFC 4648.")
(license license:isc)))
+
+(define-public ocamlify
+ (package
+ (name "ocamlify")
+ (version "0.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri name version 1209))
+ (sha256
+ (base32
+ "1f0fghvlbfryf5h3j4as7vcqrgfjb4c8abl5y0y5h069vs4kp5ii"))))
+ (build-system ocaml-build-system)
+ ; tests are done during build
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check))))
+ (home-page "https://forge.ocamlcore.org/projects/ocamlify")
+ (synopsis "Include files in OCaml code")
+ (description "OCamlify allows to create OCaml source code by including
+whole files into OCaml string or string list. The code generated can be
+compiled as a standard OCaml file. It allows embedding external resources as
+OCaml code.")
+ (license license:lgpl2.1+))); with the OCaml static compilation exception